
Trip Server User Guide

Frank Dean



This User Guide is for using Trip, version 2.3.0, 18 September 2023 in a browser. Trip is
an application supporting trip recording and itinerary planning.

Copyright c© 2021-2023 Frank Dean



i

Table of Contents

1 Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

2 Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

3 Remote Logging . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

4 Tracking . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
4.1 List Tracks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
4.2 Show Map . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
4.3 Download Tracks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
4.4 Copy Tracks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

5 Tracker Info . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
5.1 Download TripLogger Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6

6 Track Sharing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
6.1 Amend Share Details . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
6.2 Activating and Deactivating Shares . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
6.3 Deleting Shares . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

7 Itineraries . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
7.1 Itinerary Notes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
7.2 Map . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8
7.3 Live Map . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
7.4 Sharing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
7.5 GPX Upload . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
7.6 GPX and KML Downloads . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
7.7 Download Full Itinerary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
7.8 Add Waypoint . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
7.9 Creating a New Route . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
7.10 Creating Waypoints using the Map . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
7.11 Amending Routes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
7.12 Copying and Renaming Routes and Tracks . . . . . . . . . . . . . . . . . . . . 12
7.13 Copying and Pasting between Itineraries . . . . . . . . . . . . . . . . . . . . . . 12
7.14 Moving Waypoints . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
7.15 Joining Routes and Tracks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
7.16 Editing Tracks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
7.17 Split Track . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

7.17.1 Split Segment . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
7.18 Editing Route Points . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13



ii

7.19 Duplicating the Itinerary . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
7.20 Assigning Colours to Routes and Tracks . . . . . . . . . . . . . . . . . . . . . . 14
7.21 Convert Tracks to Routes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
7.22 Simplify Track . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

8 Itinerary Search . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

9 My Account . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
9.1 Change Password . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
9.2 Upload TripLogger Settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

10 Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
10.1 Tracking Page Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
10.2 Tracker Info Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
10.3 Track Sharing Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

10.3.1 Location Sharing Form Shortcut Keys . . . . . . . . . . . . . . . . . . . 18
10.4 Itinerary List Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

10.4.1 Itinerary Edit Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
10.4.2 Itinerary Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

10.4.2.1 Itinerary Sharing Shortcut Keys . . . . . . . . . . . . . . . . . . . . 20
10.4.2.2 Itinerary Import Shortcut Keys . . . . . . . . . . . . . . . . . . . . . 20
10.4.2.3 Itinerary Track Edit Shortcut Keys . . . . . . . . . . . . . . . . . 21
10.4.2.4 Itinerary Track Segment Edit Shortcut Keys . . . . . . . . 21
10.4.2.5 Itinerary Route Edit Shortcut Keys . . . . . . . . . . . . . . . . . 22
10.4.2.6 Itinerary Join Path Shortcut Keys . . . . . . . . . . . . . . . . . . 22

10.5 My Account Shortcut Keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23



1

1 Introduction

TRIP - Trip Recording and Itinerary Planner, is a web-based application supporting trip
recording and itinerary planning.

The intended use is for a hiker, mountain-biker or other adventurer, to be able to publish
and share their planned itinerary, then subsequently log their positions at intervals, allowing
someone else to be able to monitor their progress.

In the event of contact being lost, the plans and tracking information can be passed to
rescue services etc., to assist with locating the missing adventurer.

The application is open-source (https://en.wikipedia.org/wiki/
Open-source_software) and can be obtained from https://www.fdsd.co.uk/trip-server-2/.

The following features are provided:

• Remote tracking client applications such as TripLogger Remote for iOS
(https://www.fdsd.co.uk/triplogger/) or GPSLogger for Android
(http://code.mendhak.com/gpslogger/) can be used to submit locations
to the server.

• Sharing tracks with others.

• Viewing tracks on a map provided by a tile server, e.g. OpenStreetMap tiles.
(https://www.openstreetmap.org/)

• Creating and sharing itineraries using the Markdown markup language.
(https://daringfireball.net/projects/markdown/)

• Using the map, interactively creating routes and waypoints for an itinerary.

• Uploading and downloading routes, tracks and waypoints for an itinerary as a GPX
(http://www.topografix.com/gpx.asp) file.

• Viewing routes, tracks and waypoints of an itinerary on the map.

• Splitting, simplifying and joining routes and tracks.

• Deleting individual points from routes and tracks.

• Account maintenance – uploading TripLogger settings.

• Account maintenance – password change.

• Itinerary shares report – list shared itineraries including nicknames.

• Itinerary search by coordinate and radius.

• Administration – user management.

• Administration – tile usage report.

https://en.wikipedia.org/wiki/Open-source_software
https://en.wikipedia.org/wiki/Open-source_software
https://www.fdsd.co.uk/trip-server-2/
https://www.fdsd.co.uk/triplogger/
https://www.fdsd.co.uk/triplogger/
http://code.mendhak.com/gpslogger/
http://code.mendhak.com/gpslogger/
https://www.openstreetmap.org/
https://www.openstreetmap.org/
https://daringfireball.net/projects/markdown/
https://daringfireball.net/projects/markdown/
http://www.topografix.com/gpx.asp
http://www.topografix.com/gpx.asp
https://www.fdsd.co.uk/triplogger/
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2 Overview

To access the system, you will need to request the administrator of the TRIP installation
to create an account for you, using your e-mail address and providing you with an initial
password. You should Section 9.1 [Change Password], page 16, after your first login.

Thereafter you will be able to login to the system using the provided e-mail address and
associated password. The application uses nicknames to identify users as a way of avoiding
disclosure of e-mail addresses between users. In order to share your information with other
users, you will need to know their nickname.

Note: nicknames are case-sensitive. (https://en.wikipedia.org/wiki/
Case_sensitivity)

https://en.wikipedia.org/wiki/Case_sensitivity
https://en.wikipedia.org/wiki/Case_sensitivity
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3 Remote Logging

Currently, there are three remote logging applications known to work with TRIP
(https://www.fdsd.co.uk/trip-server-2/).

1. GPSLogger (http://code.mendhak.com/gpslogger/) for Android phones

2. TripLogger Remote for iOS (https://www.fdsd.co.uk/triplogger/) for Apple
Watch, iPhones and iPads

3. Traccar Client (https://www.traccar.org/client/) also for Apple iPhones and
iPads

TripLogger Remote is an iOS application providing various options to minimise battery
use of the iPhone or iPad. It also supports the Apple Watch Series 3 onwards. If you would
like to help test future versions of this app, please contact support@fdsd.co.uk.

Instructions for configuring these application are displayed on the Tracker Info page of
the web application, See Chapter 5 [Tracker Info], page 6. There are also instructions for
using the TripLogger Remote app.

https://www.fdsd.co.uk/trip-server-2/
https://www.fdsd.co.uk/trip-server-2/
http://code.mendhak.com/gpslogger/
https://www.fdsd.co.uk/triplogger/
https://www.traccar.org/client/
https://www.fdsd.co.uk/triplogger/
mailto:support@fdsd.co.uk
https://www.fdsd.co.uk/triplogger/
https://www.fdsd.co.uk/triplogger/
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4 Tracking

Select Tracking from the menu to display your track log or the track log of another user
who has chosen to share theirs with you.

If another user has shared their track log with you, a selection list titled Display shared

user’s tracks will be displayed. Select the user whose tracks you wish to see.

Specify a time and date range for the track points you wish to see.

You can also specify a maximum Horizontal Dilution of Precision HDOP
(https://en.wikipedia.org/wiki/Dilution_of_precision_%28navigation%29) value
to exclude less accurate positions.

Note: Entering a Max hdop value will also exclude all positions that have no
HDOP value. Whether an HDOP value is available will depend on the features
of the GPS logging application and hardware used.

You can further filter the results to show only those that include a note by selecting the
Show notes only option.

4.1 List Tracks

Click the List tracks button to see any new locations. The page is not automatically
refreshed when a new location is received.

Restricted Sharing: When a user shares their tracks with you, they can restrict
how far back you can view their track points. In that event, the date range
shown at the top of the page may be reduced to show the actual time period
being viewed.

The following data is shown for each location. The values are those sent from the device.
The units for those values are assumed to be as follows:

• Time–localised to the web browser’s time zone.

• Latitude/Longitude–location using the WGS84 geodetic reference system.

• HDOP–Horizontal Dilution of Precision–estimated horizontal accuracy in metres.

• Altitude–metres.

• Speed–metres-per-second.

• Bearing– degrees.

• Note–optional text entered by the user for the location.

• Provider–optional data provider, e.g. GPS, Network.

• Satellites–Optional value indicating how many satellites the fix was using.

• Battery–most recently recorded battery percentage for the GPS device, where available.

To convert the speed to kilometres-per-hour, multiply by 3.6. To convert the speed in
metres-per-second to approximate miles-per-hour, multiply by 2.24. For an exact conversion
to miles-per-hour, multiply by 3,600 then divide by 1,609.344.

https://en.wikipedia.org/wiki/Dilution_of_precision_%28navigation%29
https://en.wikipedia.org/wiki/Dilution_of_precision_%28navigation%29
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4.2 Show Map

Clicking the Show map button displays all the points matching the selection criteria on a
map.

Dragging within the map area moves the map. The map can be zoomed in and out using
the plus and minus icons at the top left-hand side of the map.

If the installation supports more than one map layer, there will also be a stacked layer

icon beneath the zoom icons at the top left of the map.

While you are viewing the map, if any new track points are recorded for the user be
monitored, the map should be updated within 60 seconds, showing their latest position
within the criteria previously selected.

Live Map Date Ranges: When new track points are recorded the map respects
the date range and other criteria you have specified. If the time of the new
track points is outside the date range or does not meet the other criteria, it will
not be included on the map.

4.3 Download Tracks

Clicking the Download Tracks button initiates a browser file download of the track points
meeting the specified date range and other selected criteria. The downloaded file is in the
common GPX file format which can be imported into many Geographic information system
GIS (https://en.wikipedia.org/wiki/Geographic_information_system) based appli-
cations.

4.4 Copy Tracks

The set of track points can be copied to an itinerary as a track log. Click the Copy button,
then navigate to the intended destination itinerary. When the itinerary page is displayed,
select the Features > Edit > Paste menu option.

Note: The copy and paste operations must be performed in the same browser
session.

The copy operation does not copy the entire detail of the items being copied,
instead just copying a reference to them together with any criteria used to select
them. Should the results change in between the copy and paste operation,
different values may be pasted from those displayed at the time the copy was
initiated.

http://www.topografix.com/gpx.asp
https://en.wikipedia.org/wiki/Geographic_information_system
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5 Tracker Info

Select Tracker Info from the menu to display information on setting up a tracker client
application.

If you are using the TripLogger Remote for iOS app, you only need this page
to ascertain the Device identifier which is a Universally Unique Identifier
(https://en.wikipedia.org/wiki/Universally_unique_identifier) (UUID). All the
other information is for customising another client app. The UUID consists of a string
of 32 characters separated by four dashes. This value needs to be copied, ideally by
cut-and-paste, into the User identifier field in the app’s settings page.

If you think there is the slightest possibility that your UUID may have been exposed to
an unauthorised person, simply click the Generate new tracking ID to immediately revoke
the previous UUID and generate a new one. There is absolutely no harm in creating new
ones as frequently as you like. Just make sure to update the client application you are using
with the new UUID and test that it successfully reports your location to the remote server.

5.1 Download TripLogger Settings

You can upload the settings from the TripLogger Remote for iOS app to the website as
described in Section 9.2 [Upload TripLogger Settings], page 16.

Clicking on the Download Updated TripLogger Settings button will download those
settings, updating them with the latest user UUID that you may have generated. The
settings can then be imported into the TripLogger app. This can be easier than trying to
copy and paste the UUID from a browser window etc.

If you have never uploaded any settings, this option creates and downloads some default
values that you can import into TripLogger. The values used for the default settings are
configured by the administrator of your TripServer website. This procedure is intended for
use when you are performing the app’s initial configuration.

The downloaded file contains your current UUID, so, if you intend to share the file with
someone else, you should generate a new tracking UUID and import that into TripLogger
before passing the previous file containing the old UUID to anyone else.

https://www.fdsd.co.uk/triplogger/
https://en.wikipedia.org/wiki/Universally_unique_identifier
https://en.wikipedia.org/wiki/Universally_unique_identifier
https://www.fdsd.co.uk/triplogger/
https://en.wikipedia.org/wiki/Universally_unique_identifier
https://www.fdsd.co.uk/triplogger/
https://www.fdsd.co.uk/triplogger/
https://www.fdsd.co.uk/trip-server-2/
https://www.fdsd.co.uk/triplogger/
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6 Track Sharing

The track points you record can be shared with another user, by nickname.

Nicknames: Note that nicknames are case-sensitive. (https://en.wikipedia.
org/wiki/Case_sensitivity)

You can limit the exposure of your track points to a point in time that is the lesser of
the following:

• the most recently logged point

• a maximum time period in any event

The latter period effectively overrides the former, so there is little advantage in setting
a most recently logged period of time that is longer than the overall maximum time period.

Click on the Track Sharing menu option to display the Track Sharing page. The page
lists any tracks you are already sharing with another user.

Click the New button to share your tracks with another user. Enter the user’s nickname
and set any date range constraints you wish to apply. Check the Active checkbox when
you’re ready to start sharing.

6.1 Amend Share Details

To amend the details of a share, select the checkbox next to the appropriate user in the list
and click Edit selected. The details are then displayed in the form below the list. Amend
the periods and click the Save button to update the list of shares.

6.2 Activating and Deactivating Shares

You can activate or deactivate location sharing by selecting one or more nicknames from
the list and clicking the Activate or Deactivate buttons.

6.3 Deleting Shares

Although deactivating a shared location stops the relevant user from seeing your location
history, you can delete the location sharing altogether. The effect is the same, other than
the nickname is no longer shown in the list. Select one or more users and click the Delete
selected button.

https://en.wikipedia.org/wiki/Case_sensitivity
https://en.wikipedia.org/wiki/Case_sensitivity
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7 Itineraries

Itineraries provide the ability to record information about a specific trip, together with
useful waypoints and routes. You may also wish to show and share previous track logs that
relate to the trip or add track logs after the trip for future reference.

Additionally you can create and modify routes and waypoints. You can also modify
track logs.

Although routes and tracks are quite similar in that they both can denote a path, they
are treated a little differently by the system.

• Routes are intended to be something that is planned. Therefore new ones can be
created and points can be added to existing ones. Two or more routes can also be
joined.

• Tracks are intended to relate to points that have been visited. Each point must have
a time related to it. Additionally, tracks can be split into multiple segments. Each
segment represents a logical break in a track, which might be due to stopping and
restarting a track or losing the GPS signal for a while. New points cannot be added to
a track. However, points can be removed, tracks and their segments can be split and
joined.

Itineraries are listed in descending start date order. Itineraries with no dates are listed
in alphabetical order prior to those with dates.

You can only edit itineraries that you created yourself. You cannot edit itineraries shared
with you by others.

7.1 Itinerary Notes

To create a new itinerary, select Itineraries from the main menu and click the New button.

When you first create an itinerary, you must give it a title and can optionally enter start
and end dates together with some descriptive text.

The text is interpreted following the syntax of Markdown (https://daringfireball.net/projects/markdown/)
as created by John Gruber. Markdown is a wonderful way of being able to write markup
in a format that is very presentable in its original text form and also efficiently displayed
as formatted HTML on the web.

There are various flavours of the Markdown syntax and whilst the current
implementation uses the cmark (https://github.com/commonmark/cmark) library
which follows the CommonMark (https://commonmark.org) standard, it is advised
that you don’t use the extended features beyond that of the original Markdown
(https://daringfireball.net/projects/markdown/) specification, in case this
application needs to employ a different implementation in the future.

7.2 Map

The map can be rotated on touch devices by touching and twisting with two fingers. On a
system with a keyboard, the map can be rotated by holding down the shift and alt keys
simultaneously while dragging with the mouse. When the map as been rotated, an arrow
icon is displayed in the top right corner of the map, pointing north.

Click on the north arrow icon to reset the map orientation.

https://daringfireball.net/projects/markdown/
https://github.com/commonmark/cmark
https://commonmark.org
https://daringfireball.net/projects/markdown/
https://daringfireball.net/projects/markdown/
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7.3 Live Map

One or more live tracks can be viewed on an itinerary map. From the itinerary page,
optionally select any routes, waypoints and tracks and click the Show map button.

To see live track logs on the map, click the settings (gear) control displayed near the
top right of the map. A list of users who are sharing their tracks with you are displayed,
including yourself. You can modify the start range date and time for displaying locations
and also filter the reported locations to only include those less than a maximum HDOP
value. You can also modify how frequently the map checks for updates by altering the value
for Refresh interval (seconds).

If your browser supports providing your position, you can use it to track your own
position. Generally, it is likely to be better to log your locations using one of the client
applications, but this facility is provided as a fallback, should it be more convenient to use
the browser. Bear in mind some browsers have an option to reduce the accuracy of your
position for privacy reasons.

When the Track & record yourself checkbox is enabled, the browser will occasionally
report your position. The positions will be added to your track log with the provider

attribute set to web-browser and shared with any other users that you have given per-
mission to. You can minimise the frequency of these updates by changing the value for
Tracking interval (seconds). The actual frequency of updates is ultimately dictated by
the browser.

Click the Start or Apply button to put your choices into effect.

Clicking the Stop button stops both the live updates of tracked locations as well as
stopping logging your own locations.

7.4 Sharing

Sharing of itineraries is treated quite separately to that of sharing tracks, although when
viewing an itinerary map you can choose to see the track points shared by others even if
you haven’t shared the itinerary with them. In fact this is the only place where you can
view and monitor the progress of multiple users.

To access itinerary sharing, select the Sharing menu option from the Itinerary tab of
the the itinerary page.

The list of any existing itinerary shares is displayed. You can choose one or more of the
shares and click Activate or Deactivate buttons to change their activation status. You
can also choose to delete the share, although this has the same effect as simply deactivating
the share, but additionally removes the nickname from the list.

Click the New button to start sharing the itinerary with someone else. Enable the Active
checkbox to actually enable sharing.

7.5 GPX Upload

You can import waypoints, tracks and routes from a standard GPX file. Not all the possible
attributes within the GPX file are supported, so keep the original if the contents might be
important.

Importing GPX Files: Some sources of GPX files create waypoints for every
point on a route which can make a mess of an existing itinerary resulting in a
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laborious cleanup operation. If you do not fully know the contents of a GPX
file you wish to import, create a new itinerary for temporary purposes and
import the file into the temporary itinerary. Check the contents and delete any
elements from the itinerary that are not required. You can then use the copy-
and-paste functionality to copy the desired contents to the ultimately intended
itinerary.

7.6 GPX and KML Downloads

Select one or more routes, tracks and waypoints, then select the Features > Transfer >

Download GPX menu option from the itinerary page, to download the chosen items in the
GPX format.

The GPX file format can be imported into many Geographic Information System (GIS)
based applications.

The KML file format is recognised by some GIS based applications, in particular Google
Earth. (https://earth.google.com/)

7.7 Download Full Itinerary

The full details of the itinerary, including the dates, text, sharing, routes, waypoints
and tracks can be downloaded by selecting the Features > Transfer > Download Full

Itinerary menu option on the Itinerary page. The downloaded file is in the YAML
(https://yaml.org "YAML Ain’t Markup Language") format, a text file format that can
be readily understood by humans.

The YAML file can either be saved and used as a long-term backup or be imported into
another instance of a TripServer application. The itinerary can be imported by clicking on
the Import button on the itineraries page.

If you are creating a backup, it is a good idea to also select all the GIS attributes (routes,
waypoints and tracks) and export them in the GPX format, as this is a common format
that can be imported into many other applications.

7.8 Add Waypoint

Select the Features > Add waypoint menu option of the itinerary page to add a new way-
point to the route.

Optionally give the waypoint a name. A valid position/location is required.

A variety of common formats are recognised when entering a position.

Position Recognition: To be sure that the intended format has been recognised
correctly, it is recommended you select the appropriate source position from
the Display position format selection list and check the output matches the
expected values.

Tip: If you are having difficulty persuading the system to recognise a particular
format, enter a simple comma separated latitude and longitude value appropri-
ate for the region, then select the Display position format you wish to use.
The formatting output below the select list will indicate a format you can enter
values in. Values are case-significant.

http://www.topografix.com/gpx.asp
https://en.wikipedia.org/wiki/Geographic_information_system
https://earth.google.com/
https://earth.google.com/
https://yaml.org "YAML Ain't Markup Language"
https://yaml.org "YAML Ain't Markup Language"
https://www.fdsd.co.uk/trip-server-2/
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7.9 Creating a New Route

Optionally select one or more waypoints, routes or tracks in the itinerary that will help to
zoom the map into the intended area.

Select the Features > View > Show map menu option to display the selected features on
the map. Pan and zoom to the desired area.

To start creating a new route, click on the new route icon at the top right of the page.
The icon depicts a slight left turn sign.

Click on each position you want the route to follow. When you have finished entering
all the points for the route, either click the Finish button adjacent to the new route icon

or click on the last point of the route.

On a system with a keyboard and mouse, holding down the shift key allows a freehand
route to be created.

When you view the itinerary page all the new routes are at at the end of the list of
routes and are unnamed having only an ID. To edit the route’s attributes, select the route
in the itinerary page and select the Features > Edit > Attributes menu option.

Click the edit icon to modifying an existing route. Click and drag on existing nodes,
or click and drag on other parts of the route to create a new node. Nodes can be deleted by
holding down the alt key and clicking on the node to be deleted. On touch screen devices
double-click the node to delete it.

7.10 Creating Waypoints using the Map

In addition to being able to create routes on the itinerary map, you can add waypoints by
clicking the new waypoint icon (flag symbol) at the top right of the page. Click on the
map at the location you wish to create a waypoint. A new anonymous waypoint is created.

When you view the itinerary page all the new waypoints are at at the end of the list
of waypoints and are unnamed having only an ID. To edit the waypoint’s attributes, select
the waypoint in the itinerary page and click the Edit attributes button.

7.11 Amending Routes

To amend a route, select it in the itinerary page then select the Features > View > Show

map menu option of the itinerary page. To commence editing the routes on the itinerary
map, click the edit icon at the top right hand side of the map. The icon represents a
pencil inside a square.

Existing points can be dragged to a new location. To create a new point in between the
existing points, start dragging the line in between two points. A new point is created when
you finishing dragging.

Click the Save button adjacent to the edit icon at the top right hand side of the map
to finish make changes. Click the Cancel button to abandon the changes.

Nodes can be deleted by holding down the alt key and clicking on the node to be deleted.
On touch screen devices double-click the node to delete it.
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7.12 Copying and Renaming Routes and Tracks

Route and track names and colours can be amended by selecting the route or track in the
itinerary page and selected the Features > Edit > Path menu option of the itinerary page.

Copying Routes and Tracks: To make copies of waypoints, tracks and routes,
select them in the itinerary list, click the Copy button, then click the Paste

button.

7.13 Copying and Pasting between Itineraries

Select the waypoint, routes and tracks in the itinerary list to be copied, click the Copy

button at the bottom of the itinerary page. Navigate to the target itinerary, then click the
Paste button.

Copy and Paste: The copy and paste operations must be performed in the same
browser session.

The copy operation does not copy the entire detail of the items being copied,
instead just copying a reference to them together with any criteria used to select
them. Should the results change in between the copy and paste operation,
different values may be pasted from those displayed at the time the copy was
initiated.

7.14 Moving Waypoints

To move a waypoint to a different position, select it in the itinerary page, then select the
Features > View > Show mapmenu option. To commence editing the routes on the itinerary
map, click the edit icon at the top right hand side of the map. The icon represents a pencil
inside a square.

Drag the waypoint to the new location and click the Save button adjacent to the edit

icon at the top right hand side of the map.

Tip: Multiple routes and waypoints can be selected for editing on the map in
a single session.

You can also select tracks to be displayed on the map whilst editing routes and
waypoints, but you cannot modify the tracks interactively on the map.

7.15 Joining Routes and Tracks

Two different itinerary routes or itinerary tracks can be joined together to create a sin-
gle route or track. Tracks cannot be joined to routes and vice versa. To simplify these
instructions, both routes and tracks are referred to as paths in these instructions.

Select all the paths to be joined and click the Join paths button at the bottom of the
itinerary page.

Tip: To make it easier to visualise the different paths, give them each a different
colour before attempting to join them.

A map is displayed showing each of the paths in their individual colours.

Use the Up and Down buttons to reorder the paths into the desired order.

Once satisfied with your choices, optionally edit the new path name and select a colour.
Then click the Join button to make a copy of the combined paths.
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7.16 Editing Tracks

Tracks can be edited by;

• splitting track segments

• splitting the track between segments to form two tracks

• deleting individual points

Select the track to be edited by clicking the Edit path button at the bottom of the
itinerary page.

7.17 Split Track

If a track has multiple segments, selecting a segment and clicking the Split track button
splits the existing track into two. The selected and following segments are moved from the
current track to a new one.

7.17.1 Split Segment

Click on the segment ID to display the track segment points.

Clicking on the checkbox in the table header above the list of segments, selects all
segments and displays them on the map below.

If there are more than 10 track segment points, you can page forwards and backwards
through them.

Tip: Whether the checkbox in the table header was selected when you navigate
to a new page is remembered. Therefore, selecting the checkbox and navigating
through the pages allows you to quickly review a track segment.

To split a segment into two, select a single track segment checkbox and click the Split
segment button. The selected track segment point and all subsequent ones in the same
segment are moved from the current segment into a new segment.

Tip: To split a track at a particular track segment point, split the track in two
operations. Firstly split the track segment at that track segment point, then
secondly split the track at the new track segment.

7.18 Editing Route Points

In addition to being able to edit routes on the itinerary map, you can perform some opera-
tions using the Features > Edit > Path menu option of the itinerary page which cannot be
easily accomplished on the map. E.g. Splitting the route. Sometimes it can also be difficult
to select and delete points on the map when they are very close together, so navigating
through the points in the Edit path mode provides another method to identify and delete
them.

Editing routes is very similar to editing tracks as described above.

7.19 Duplicating the Itinerary

The Features > Edit > Create duplicate itinerary menu option of the itinerary page
creates a duplicate of the current itinerary. The new itinerary is displayed once it has been
created.
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7.20 Assigning Colours to Routes and Tracks

This option is intended to make it easy to quickly give routes and tracks different colours,
to more easily identify them on the map.

Select select the routes and tracks you wish to change and choose the Assign colours

to routes and tracks from the Edit menu of the Features tab. After confirmation each
colour defined on the system is assigned to each route and then each track in sequence. If
there are more tracks and routes selected than there are colours, the colours are repeated
from the beginning again.

7.21 Convert Tracks to Routes

To create routes from tracks or vice versa, select the routes and tracks you wish to con-
vert and choose the Features > Edit > Convert tracks and routes menu option. After
confirmation, a copy of each route and track is created.

Note: When converting a route to a track, each track point is given a time stamp
from the early 20th century, with one second intervals, to make it clear they are
artificial. (Some systems reject tracks that have no timestamps.) Conversely
converting tracks to routes loses the time information.

7.22 Simplify Track

Sometimes, a track log has a high frequency of points. You might wish to reduce the number
of points, (simplifying the path), perhaps before converting it to a route, or just to make it
smaller to fit the maximum point constraint of some software or GPS systems.

Trip uses the Ramer—Douglas—Peucker (https://en.wikipedia.org/wiki/
Ramer%E2%80%93Douglas%E2%80%93Peucker_algorithm) simplification algorithm
implemented by the OpenLayers mapping project (https://openlayers.org/).

Select a single track, then choose the Features > Edit > Simplify track menu option.

The selected track is displayed on a map. A slider control is used to change the tolerance
value. The higher the tolerance value is, the more likely points are reduced.

The display shows the total number of points originally in the track together with an es-
timated total number of points that remain after simplification. A preview of the estimated
final track is displayed on the map, together with the original track shown translucent, so
that you can judge the impact of the simplification.

The first and last point of each track segment are always retained. If that behaviour is
undesired, consider joining the segments before-hand, as described in Section 7.15 [Joining
Routes and Tracks], page 12.

Selecting the Save button saves a copy of the track, appending (simplified) to the
track name.

Note: Due to some technical implementation limitations, the number of points
in the final track may differ from the preview by a small amount, so checking
the new track after simplification is advised.

Tip: To simplify a route, convert it to a track, simplify the track and convert the
new track to a route. However, if the route contains individual point attributes
(name, comment, description or symbol) these are lost when converting to a
track.

https://en.wikipedia.org/wiki/Ramer%E2%80%93Douglas%E2%80%93Peucker_algorithm
https://en.wikipedia.org/wiki/Ramer%E2%80%93Douglas%E2%80%93Peucker_algorithm
https://openlayers.org/
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8 Itinerary Search

Itineraries can be searched for by their location and a radius. Click the Search button at
the bottom of the Itineraries list page.

Enter the position of the centre of the area to search, in any of the formats supported
when adding a waypoint. Section 7.8 [Add Waypoint], page 10, Enter the radius in kilome-
tres in the Distance input field. (E.g. 0.125 for 125 metres.) Click Search to perform the
search.

Note: If a waypoint been copied using the Features > Edit > Copy menu op-
tion of the Itinerary page, it is used to pre-populate the search position for
convenience. E.g. if you want to search an area, drop a waypoint on the
itinerary map, copy it using the menu option, then initiate the search.

The itinerary search results shows a list of itineraries that have either waypoints, tracks
or routes with a point lying within the search radius. Use your browser’s options to open
itineraries of interest in a separate tab or window to examine their contents without losing
your search results.

Note: A path that intersects with the search radius but doesn’t actually have
a point within it, is excluded from the results.
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9 My Account

9.1 Change Password

Click on the Change password option of the Account page to change your current password.
You need to enter your current password before any changes can be made. Then enter your
new password.

As you type the password, the system evaluates it’s apparent strength. The Save button
remains disabled until the password is apparently sufficiently strong. Repeat the password
in the next field, then click the Save button. Hints and warnings are displayed to assist in
choosing a strong password.

9.2 Upload TripLogger Settings

If you are using the TripLogger Remote for iOS app, you can export your settings from
TripLogger, save them to a file, then upload them by clicking the Choose File option, se-
lecting the saved settings file and then clicking the Upload button to store the settings in
the database. This can act as a quick backup of your settings, but can also make it easier
to update your unique user UUID. See Section 5.1 [Download TripLogger Settings], page 6,

https://www.fdsd.co.uk/triplogger/
https://en.wikipedia.org/wiki/Universally_unique_identifier
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10 Shortcut Keys

The application implments shortcut keys (also known as access keys) for most options.
Unfortunately, whilst the HTML specification allows such keys to be defined, it does not
specify a method for indicating where they exist.

See accesskey (https://developer.mozilla.org/en-US/docs/Web/HTML/
Global_attributes/accesskey) in the MDN developer documentation for a list of the
key combinations to use to activate a shortcut key.

The implemented shortcuts keys are listed in the following sub-sections.

10.1 Tracking Page Shortcut Keys

l

List tracks

m

Show map

d

Download tracks

y

Copy

r

Reset

10.2 Tracker Info Shortcut Keys

g

Generate new tracking ID

d

Download TripLogger Settings

10.3 Track Sharing Shortcut Keys

a

Toggles checkboxes in list of shares

v

Activate

x

Deactivate

d

Delete selected

https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/accesskey
https://developer.mozilla.org/en-US/docs/Web/HTML/Global_attributes/accesskey
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e

Edit selected

w

New

10.3.1 Location Sharing Form Shortcut Keys

a

Activate

s

Save

c

Cancel

r

Reset

10.4 Itinerary List Shortcut Keys

n

next page

p

previous page

g

goto page

w

New itinerary

i

Import itinerary

s

Search

r

Itinerary shares report

10.4.1 Itinerary Edit Shortcut Keys

s

Save

c

Cancel

r

Reset
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10.4.2 Itinerary Shortcut Keys

i

select itinerary tab

f

select features tab

e

Edit

c

Close

m

Show map

a

toggle selecting all checkboxes

r

toggle selecting all routes

w

toggle selecting all waypoints

t

toggle selecting all tracks

y

Copy

b

Edit Attributes

l

Assign colours to routes and tracks

z

Edit Path

p

Paste

q

Add waypoint

v

Convert tracks and routes

s

Simplify track
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d

Delete selected items

j

Join paths

u

Upload GPX

g

Download GPX

k

Download KML

n

Download full itinerary

o (read-only mode)

Show Markdown

h (read-only mode)

Hide Markdown

x

Create duplicate itinerary

10.4.2.1 Itinerary Sharing Shortcut Keys

v

Activate

x

Deactivate

d

Delete selected

w

New

c

Close

10.4.2.2 Itinerary Import Shortcut Keys

f

Choose file

u

Upload

c

Cancel
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10.4.2.3 Itinerary Track Edit Shortcut Keys

a

toggle selecting all checkboxes

g

Go

n

next page

p

previous page

d

Delete segments

s

Split track

m

Merge segments

c

Close

10.4.2.4 Itinerary Track Segment Edit Shortcut Keys

a

toggle selecting all checkboxes

g

Go

n

next page

p

previous page

d

Delete points

s

Split segment

c

Close
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10.4.2.5 Itinerary Route Edit Shortcut Keys

a

toggle selecting all checkboxes

g

Go

n

next page

p

previous page

d

Delete points

s

Split route

r

Reverse

c

Close

u

Up (first path)

d

Down (first path)

10.4.2.6 Itinerary Join Path Shortcut Keys

n

Name

l

Colour

j

Join

c

Cancel

10.5 My Account Shortcut Keys

f

Choose File

u

Upload
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